Problem
WHMCS displays one of the error messages below when it detects a conflict between your settings and the admin directory path that you are trying to access:
You are attempting to access the admin area via a directory that is not configured.
or
You are attempting to access the admin area via a directory that is different from the one configured.
or
You are attempting to access the admin area via a custom directory, but we have detected the presence of a default "admin" directory too.
or
The request path cannot be resolved.
Cause
These errors appear due to the following issues:
- The
$customadminpathline does not appear or is invalid in the WHMCSconfiguration.phpfile. - You are attempting to access the wrong directory.
- A recent update uploaded files to the default
admindirectory. As a result, the files in your custom admin directory may not be up-to-date.
Solution
Update the configuration.php file with the correct path, and make certain to use it when accessing the Admin Area.
login. If it does, choose a different custom name.If you have performed an update recently:
- Make certain that you uploaded all of the latest files to your custom admin directory.
- Delete the default
admindirectory and its contents.
If you continue to see the error message, revert your admin directory name to admin in order to regain access. Then, contact our support team for assistance.
Last modified: 2025 March 19