cPanel License Missing IP Address

Problem

The system is not successfully syncing IP addresses for licenses that you provision and manage using the cPanel Licensing addon module.

Cause

You have not correctly configured the necessary custom fields in WHMCS.

The cPanel Licensing addon module sets license IP addresses by checking for a Dedicated IP or IP Address custom field. These custom fields might not exist, or you may have renamed them, causing the system to be unable to find them.

Solution

To resolve this issue, go to Configuration () > System Settings > Custom Fields. Ensure that a Dedicated IP or IP Address custom field exists and that the field uses the correct name.

Last modified: January 16, 2025