ImportAssist Unable to Connect
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Problem
You may see the following error while attempting to perform an import using ImportAssist:
Unable to connect to the database
Cause
This error indicates that ImportAssist cannot establish a connection to the source database from which it is importing the data. This may be due to an issue with the database connection details in ImportAssist, a remote server configuration, or the MySQL® user’s configuration.
Troubleshooting
To troubleshoot this further, check whether the following statements are true:
- The database connection details in ImportAssist are valid.
- The database host is valid relative to the WHMCS installation that is using ImportAssist. If the source database is on the same server, try using
localhost
or127.0. 0.1
. - If the source data is remote, the server allows remote MySQL access.
- The MySQL service on the source server is online and remotely accessible.
- The specified MySQL user has full access to the desired database.
Solution
Fix the discovered issue and retry the import.
Last modified: October 30, 2024