CloudFlare Proxy Check Errors

Problem

You see one of the following CloudFlare® Proxy Check errors at Configuration () > System Health:

  • WHMCS is running behind a CloudFlare proxy, but you have not configured proxy settings. This may cause login sessions to end prematurely. Click here to automatically reconfigure your CloudFlare proxy settings. (WHMCS 8.11 and later)
  • WHMCS may be operating behind a proxy or CDN, but you have not configured trusted proxy settings using CloudFlare IP addresses. This may cause login sessions to end prematurely. Apply settings now to correct this issue. (WHMCS 8.10 and earlier)

You may also see login sessions that end prematurely.

If you do not use CloudFlare but see frequent unexpected logouts, see Frequent Logouts.

Cause

WHMCS detected that you are using CloudFlare, but there is a misconfiguration in your settings for trusted proxies.

Solution

Click the link in the error message. The system will automatically correct the misconfiguration.

Last modified: September 18, 2024