Invalid Licenses on HostGator

Problem

HostGator customers may see an Invalid License error when they try to access the Admin Area.

You may also encounter storage-related errors, like an inability to attach files to client accounts or support tickets or problems applying automatic updates within WHMCS.

Cause

We have observed HostGator making mass changes to the home directory. This is presumed due to a server migration or configuration changes.

Troubleshooting

To confirm this, check the Home Directory value within cPanel to see if it has changed from:

/home/username

to:

/home2/username

Solution

To resolve this issue:

  1. Contact HostGator Support to reissue your WHMCS license key. This will restore access to the WHMCS Admin Area.

  2. In the Admin Area, go to Configuration () > System Settings > Storage Settings.

  3. Click the Configurations tab.

  4. Click the Play icon button for each storage location.

    • If the check succeeds, proceed to testing the next storage location.

    • If the check fails with a red Configuration settings could not be verified. error:

      1. Click the + icon under Add New Configuration.
      2. Enter the new path to the storage location.
        Contact HostGator support if you are unsure of the correct path to use.
      3. Click Save Changes.
        Storage Settings
  5. When you have tested all storage locations, choose the Settings tab and use the menus to select the correct storage locations.
    Storage Settings

  6. Click Migrate where it appears as available. For the other storage locations, click Switch.

  7. Go to Utilities > Update WHMCS.

  8. Click Configure Update Settings in the top-right corner.

  9. Adjust the Temporary Path setting.

  10. Click Save Changes.

Last modified: October 30, 2024