No Connection Errors

Problem

While attempting to log in as an admin, you see the following error:

No Connection

Cause

This error indicates that there is a problem preventing your server from communicating with the WHMCS licensing server.

This is often due to a cURL or DNS resolution problem.

Troubleshooting

To test the connection between your server and the WHMCS license server, go to the following page in your WHMCS installation:

/admin/login.php?conntest=1

For example, if the Admin Area is at http://example.com/admin/login.php, go to http://example.com/admin/login.php?conntest=1.

A successful test result looks like:

    Testing Connection to 'https://a.licensing.whmcs.com/1.0/test'...
    URL resolves to 208.74.120.154 ...
    Response Code: 200
    Connection Successful!

Solution

Make certain that your DNS resolves whmcs.com to the correct IP address.

Then, work with your system administrator or hosting provider to resolve any cURL connectivity issues that the test above reveals.

Shared and Reseller Hosted Customers

Some hosting providers may operate very restrictive environments, which results in a No Connection error despite the above test returning a successful result.

In this situation, changing the PHP version to 7 can resolve the error.

For more information, see the HostGator documentation.

Last modified: October 30, 2024