Problem
After applying an update, some WHMCS features do not function normally, display errors, display with poor formatting, or do not display at all. This may include features in the Client Area, shopping cart, or Admin Area.
For more information on other display issues, see General Troubleshooting.
Cause
In most cases, this behavior is due to outdated customized template files.
If you have used template files to customize the appearance of WHMCS, you must update them for use with the latest version.
Solution
If you purchased your custom template from a third-party vendor, check the corresponding WHMCS Marketplace listing for available updates and then contact the vendor to obtain them.
To resolve this issue:
- Review all of the template file changes for your new WHMCS version and each intermediary version against your custom template files in the
templates/template_name
directory, wheretemplate_name
is your template’s name.You can find the template changes between each version of WHMCS in the Release Notes. - For each change that does not appear in your custom template files, remove the red
-
line and replace it with the green+
line: - In the WHMCS Admin Area, go to Utilities > System > System Cleanup.
- Click Go under Empty Template Cache.
Last modified: October 30, 2024